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Kitware
⬣ Open-source, software R&D company
⬣ Five core areas of expertise



Kitware – Computer Vision
VIAME



Kitware – Data and Analytics



Kitware – HPC and Visualization
Trame LidarView



Kitware – Medical Computing



Kitware – Software Process
⬣ cmake, ctest, cdash



To Follow Along…
Install ParaView 5.12.0

● http://www.paraview.org 🡪 Download

http://www.paraview.org


Introduction



What is ParaView?
⬣ An open-source (BSD 3 Clause License), 

scalable, multi-platform visualization application 
based on VTK

⬣ Processing paradigms:
● distributed computing (MPI)
● shared memory multiprocessing (SMP) 

(vtkSMPTools)
● GPU processing (vtk-m).

⬣ Has an open, flexible, and intuitive user interface
⬣ Has an extensible, modular architecture based 

on open standards



ParaView on the Desktop



ParaView on the Web
Visualizer, Glance (vtk.js) 
https://blog.kitware.com/vis-on-the-web/

https://blog.kitware.com/vis-on-the-web/


Tools > Start Trace
 __ build a pipeline __
Tools > Stop Trace

ParaView Scripting - Python



ParaView Immersive and VR

OpenVR, OpenXR



ParaView for HPC



ParaView Catalyst

Simulations with Catalyst: PyFR, HPCMP CREATE HELIOS, 
PHASTA, MPAS Ocean, VPIC, RAGE, UH3D, CAM

Uses Conduit Blueprint
data description

● No need to compile 
ParaView

● No need to recompile 
when ParaView 
version changes

● Can choose insitu 
backend at runtime.



Current ParaView Usage
⬣ Used by academic, government, and commercial 

institutions worldwide.
⬣ Downloaded ~135K times per year.
⬣ HPCwire Editors’ Choice 2010/2016 and HPCwire 

Readers’ Choice 2010/2012/2015 Awards for Best 
Visualization Product or Technology.



Data Ranges
⬣ Used for all ranges of data size.
⬣ Landmarks of usage:

●6 billion structured cells (2005).

●Billions of AMR cells (2008).

●6.33 billion unstructured cells in Catalyst (2016).

●Scaling test over 1 Trillion cells (2010).



ParaView (VTK) Data Types

Uniform Rectilinear
(vtkImageData)

Non-Uniform Rectilinear
(vtkRectilinearData)

Curvilinear
(vtkStructuredData)

Polygonal
(vtkPolyData) Unstructured Grid

(vtkUnstructuredGrid)

• Partitioned Dataset
• Partitioned Dataset 

Collection
• Adaptive Mesh 

Refinement (AMR)



ParaView (VTK) Cell Types
⬣ Cell types (linear, nonlinear), interpolation
⬣ Arbitrary order Lagrange Finite Elements
⬣ Discontinuous Galerkin elements and other novel 

cell-types/function-spaces

https://examples.vtk.org/site/VTKBook/05Chapter5/#54-cell-types
https://examples.vtk.org/site/VTKBook/08Chapter8/#82-interpolation-functions
https://www.kitware.com/modeling-arbitrary-order-lagrange-finite-elements-in-the-visualization-toolkit/
https://discourse.vtk.org/t/discontinuous-galerkin-elements-and-other-novel-cell-types-function-spaces/9209
https://discourse.vtk.org/t/discontinuous-galerkin-elements-and-other-novel-cell-types-function-spaces/9209


More Information



Basic Usage



User Interface
Menu Bar

Toolbars

Pipeline Browser

Properties Panel
Information Panel

3D View



Creating a Cylinder Source
1. Go to the Sources menu and select Cylinder. 
2. Click the             button to accept the default 

parameters. 



Simple Camera Manipulation
⬣ Drag left, middle, right buttons for rotate, pan, zoom.

● Laptop: use Shift, Ctrl modifiers (see Edit > Setting > 
Camera)

● Also try holding down x, y, or z.



Pipeline Object Properties
1. Go to the Source menu and select Cylinder. 
2. Click the                button to accept the default 

parameters.
3. Increase the Resolution parameter.
4.

5.  Click the                button again.



Pipeline Object Controls

Pipeline objects

Sources
Filters
Readers
Extractors



Display Properties



Change Display Properties
1. Scroll down to the Display group.
2. Click the          Edit Color Map button. (This button 

is replicated in the toolbar.)
3. Select a new color for the cylinder.



View Properties



Change View Properties
1. Scroll down to the Display group.
2. Click the         Edit Color Map button. (This button is 

replicated in the toolbar.)
3. Select a new color for the cylinder.
4. Scroll down to the View group.
5. Turn on the Axis Grid.



Advanced Properties

Toggle
Advanced
Properties

Search
Properties



Searching Properties
1. Type “specular” in the properties search box
2. Change Specular value to 1 (makes the cylinder 

shiny)



Searching Properties
1. Type “specular” in the properties search box
2. Change Specular value to 1 (makes the cylinder 

shiny)

Other interesting properties:
• Axes Grid
• Opacity



Changing the Color Palette
1. Make sure the orientation axes are visible in the 

lower left corner.

2. Click the color palette button       and change the 
colors.

3. Try several color palettes.



Color Palettes

→ Edit Current Palette…



Undo Redo

RedoUndo

Camera
Redo

Camera
Undo



Reset ParaView

Edit → Reset Session 



Supported File Types
ParaView Data (.pvd)
VTK (.vtp, .vtu, .vti, .vts, .vtr)
VTK Legacy (.vtk)
VTK Multi Block (.vtm,.vtmb,.vtmg,.vthd,.vthb)
Partitioned VTK (.pvtu, .pvti, .pvts, .pvtr)
ADAPT (.nc, .cdf, .elev, .ncd)
ANALYZE (.img, .hdr)
ANSYS (.inp)
AVS UCD (.inp)
BOV (.bov)
BYU (.g)
CAM NetCDF (.nc, .ncdf)
CCSM MTSD (.nc, .cdf, .elev, .ncd)
CCSM STSD (.nc, .cdf, .elev, .ncd)
CEAucd (.ucd, .inp)
CGNS (.cgns)
CMAT (.cmat)
CML (.cml)
CTRL (.ctrl)
Chombo (.hdf5, .h5)
Claw (.claw)
Comma Separated Values (.csv)
Cosmology Files (.cosmo, .gadget2)
Curve2D (.curve, .ultra, .ult, .u)

DDCMD (.ddcmd)

Digital Elevation Map (.dem)

Dyna3D(.dyn)

EnSight (.case, .sos)

Enzo boundary and hierarchy

ExodusII (.g, .e, .exe, .ex2, .ex2v.., etc)

ExtrudedVol (.exvol)

FVCOM (MTMD, MTSD, Particle, STSD) 

Facet Polygonal Data

Flash multiblock files

Fluent Case Files (.cas)

GGCM (.3df, .mer)

GTC (.h5)

GULP (.trg)

Gadget (.gadget)

Gaussian Cube File (.cube)

JPEG Image (.jpg, .jpeg)

LAMPPS Dump (.dump)

LAMPPS Structure Files

LODI (.nc, .cdf, .elev, .ncd)

LODI Particle (.nc, .cdf, .elev, .ncd)

LS-DYNA (.k, .lsdyna, .d3plot, d3plot)

M3DCl (.h5)

MFIX Unstructred Grid (.RES)

MM5 (.mm5)

MPAS NetCDF (.nc, .ncdf)
Meta Image (.mhd, .mha)
Miranda (.mir, .raw)
Multilevel 3d Plasma (.m3d, .h5)
NASTRAN (.nas, .f06)
Nek5000 Files 
Nrrd Raw Image (.nrrd, .nhdr)
OpenFOAM Files (.foam)
PATRAN (.neu)
PFLOTRAN (.h5)
PLOT2D (.p2d)
PLOT3D (.xyz, .q, .x, .vp3d)
PLY Polygonal File Format
PNG Image Files
POP Ocean Files
ParaDIS Files
Phasta Files (.pht)
Pixie Files (.h5)
ProSTAR (.cel, .vrt)
Protein Data Bank (.pdb, .ent, .pdb)
Raw Image Files
Raw NRRD image files (.nrrd)
SAMRAI (.samrai) 
SAR (.SAR, .sar) 
SAS (.sasgeom, .sas, .sasdata) 
SESAME Tables

SLAC netCDF mesh and mode data
SLAC netCDF particle data
Silo (.silo, .pdb)
Spheral (.spheral, .sv)
SpyPlot CTH
SpyPlot (.case)
SpyPlot History (.hscth)
Stereo Lithography (.stl)
TFT Files
TIFF Image Files
TSurf Files
Tecplot ASCII (.tec, .tp)
Tecplot Binary (.plt)
Tetrad (.hdf5, .h5)
UNIC (.h5) 
VASP CHGCA (.CHG)
VASP OUT (.OUT) 
VASP POSTCAR (.POS) 
VPIC (.vpc)
VRML (.wrl)
Velodyne (.vld, .rst)
VizSchema (.h5, .vsh5)
Wavefront Polygonal Data (.obj)
WindBlade (.wind)
XDMF and hdf5 (.xmf, .xdmf)
XMol Molecule



Custom Data Import:
Prototype with Python

⬣ Program data 
readers right in the 
GUI.

⬣ Or use Python or 
C++ plugin.

Programmable Source - Create a 
data reader in the GUI



Load disk_out_ref.ex2
1.  Open the file disk_out_ref.ex2 from the 

examples directory.



Load disk_out_ref.ex2
1.  Open the file disk_out_ref.ex2 from the 

examples directory.
2. Click 



Data Representation



Filters Menu

~200 filters

Status bar:
• Short description
• Reason why is grayed



Calculator

Contour

Clip

Slice

Threshold

Extract Subset

Common Filters
Glyph

Stream Tracer

Warp (vector)

Group Datasets

Extract Block



Quick Launch

⬣Used for searching 
for filters by name

⬣Keyboard shortcut
● Ctrl-space for 

Windows & Linux
● Alt-space for Mac



Apply Contour
1. Select disk_out_ref.ex2 in the pipeline browser.
2. Press the contour filter.

Specify the data you 
apply the filter on

Goal



Apply Contour
3. Change parameters to create an isosurface at Temp 

= 400K.

Change to Temp

Change to 400



Apply Contour
1. Select disk_out_ref.ex2 in the pipeline browser.
2. Select the contour filter.
3. Change parameters to create an isosurface at Temp 

= 400K.
4.  



Apply ExtractSurface
1. Select disk_out_ref.ex2 in the pipeline browser.
2. From the quick launch, select Extract Surface.
3.  



Apply ExtractSurface, Clip
1. Select disk_out_ref.ex2 in the pipeline browser.
2. From the quick launch, select Extract Surface.
3.  
4. Select …           Create a clip filter.
5. Uncheck
6.  



Pipeline Browser Structure

disk_out_ref.ex2

Contour1 ExtractSurface1

Clip1



Pipeline Browser Structure

disk_out_ref.ex2

Contour1 ExtractSurface1

Clip1

Visible



Pipeline Browser Structure

disk_out_ref.ex2

Contour1 ExtractSurface1

Clip1

Not Visible



Multiview



Multiview - Disk colored by Temp
1. Select disk_out_ref.ex2 in the pipeline browser.
2. Add Clip filter.
3. Uncheck 
4.  
5. Hide Clip2 



Multiview
1. Split the view horizontally.
2. Make Clip2 visible.
3. Color surface by Temp.



Multiview
1. Split the view horizontally.
2. Make Clip2 visible.
3. Color surface by Temp.
4. Right-click view, Link Camera…
5. Click other view. 



Multiview
1. Split the view horizontally.
2. Make Clip1 visible.
3. Color surface by Temp.
4. Right-click view, Link Camera…
5. Click other view.
6. Click          and zoom in a bit.



Modifying Views



Modifying Views



Kitware SAS, Lyon

Saving a DataSet

⬣ Save Data saves the dataset output of the current active 
pipeline object

⬣ File -> Save Data
⬣ Options to configure writer

6363



Kitware SAS, Lyon

Saving a Screenshot

6464

⬣ Saves an image from the view
⬣ File -> Save Screenshot
⬣ Set Resolution and Quality



Kitware SAS, Lyon 65

Saving the State

⬣ Save the current state of the application
⬣ File -> Save State
⬣ Include Pipeline, Views, Layouts, all properties…
⬣ PVSM State file : Robust, based on proxy state

● Descriptive Approach
● Enable user to modify file path
● Use with File -> Load State
● Use for sharing with colleagues

⬣ Python State file : User-friendly, based on UI actions
● Just a python script
● Use python shell or in pvpython

6565



Reset ParaView

Edit → Reset Session 



Streamlines
1. Open disk_out_ref.ex2.  Load all variables.
2. Add Stream Tracer.
3. Change Seed Type to Point Source.
4. Uncheck Show Sphere.
5.  



Streamlines
1. Open disk_out_ref.ex2.  Load all variables.
2. Add Stream Tracer.
3. Change Seed Type to Point Source.
4. Uncheck Show Sphere.
5.  
6. From the quick launch, select Tube
7.  



Adding Glyphs
1. Select StreamTracer1.
2. Add Glyph filter.
3. Change Glyph Type to Cone.
4. Change Orientation Array and Scale Array to V.
5. Change Vector Scale Mode to Scale By Magnitude.
6. Click reset      next to Scale Factor.
7.
8. Color by Temp.



Reset ParaView

Edit → Reset Session 



Common Data Analysis Filters
Extract Selection

Plot Global Variables Over Time

Plot Selection Over Time

Plot Over Line

Probe Location



Plotting
1. Open disk_out_ref.ex2.  Load all variables.
2. Clip,       uncheck,                      ,
3. Select disk_out_ref.ex2.
4. Add Plot Over Line filter.



3D Widgets



Placing 3D Line Widget Endpoints
⬣ Use the p key to place alternating points.

● Ctrl+p places at nearest mesh point.
⬣ Use the 1 or 2 key to place the start or end point.

● Ctrl+1 or Ctrl+2 places at mesh point.
⬣ Drag the endpoints.

● Use x, y, or z key to constrain to axis.
⬣ Use widgets in Properties panel

● E.g. Use Z Axis button and then edit points to 
place from (0,0,0) to (0, 0, 10).



Plotting
1. Open disk_out_ref.ex2.  Load all variables.
2. Clip,        uncheck,                       ,
3. Select disk_out_ref.ex2.
4. Add Plot Over Line filter.
5. Once line is satisfactorily located,
6.



Interacting with Plots
⬣ Left, middle, right buttons to pan, zoom.
⬣ Mouse wheel to zoom.
⬣ Reset view to plot ranges.



Plots are Views
⬣ Move them like Views.
⬣ Save screenshots.



Adjusting Plots
1. In Display section of properties panel, turn off all 

variables except Temp and Pres.
2. Select Pres in the Display options.
3. Change Chart Axis to 'Bottom – Right'.
4. Verify the relationship between temperature and 

pressure.



Reset ParaView

Edit → Reset Session 



Volume Rendering
1. Open disk_out_ref.ex2.  Load all variables.
2. Change variable viewed to Temp.
3. Change representation to Volume.
4. In the Are you Sure dialog box, click Yes.



Transfer Function Editor



Modify Transfer Function
1. Select disk_out_ref.ex2.
2. Click Edit Color Map        .
3. Click Choose preset        .
4. Select Black-Body Radiation. Apply. Close.
5. Try adding and changing control points.



Reset ParaView

Edit → Reset Session 



Query-Based Selection
1. Open can.ex2.  Select all variables.
2. Go to last time step.
3. Edit → Find Data.
4. Top combo box: Find Cells.
5. Next row: EQPS, is >=, and 1.5.
6. Click Run Selection Query.



Query-Based Selection



Brush Selection
Surface Cell Selection
(shortcut: s)
Surface Point Selection
(shortcut: d)

Through Cell Selection
(shortcut: f)
Through Point Selection
(shortcut: g)

Select Cells (polygon)

Select Points (polygon)

Block Selection
(shortcut: b)

Interactively Select Cells

Interactively Select Points

Hover Point Query

Hover Cell Query



Adding Labels
1. Go to the last time step.
2. Interactively Select Cells
3. Open Find Data.
4. In the Cell Labels chooser, select EQPS.
5. Try again: Interactively Select Cells 
6. Similarly: Hover Cells On



Reset ParaView

Edit → Reset Session 



Visualizing Large 
Models



Data Parallel Pipelines
⬣ Duplicate pipelines run independently on different 

partitions of data.



Data Parallel Pipelines
⬣ Many operations will work regardless.

● Example: Clipping.



Data Parallel Pipelines
⬣ Many operations will work regardless.

● Example: Clipping



Data Parallel Pipelines
⬣ Many operations will work regardless.

● Example: Clipping



Reader

Filter

Filter

Reader

Filter

Filter

MPIX/N  GB X/N GB

N component Data 
Parallelism for X GByte

…

Render 
Server
Render 
Server
Render 
Server
Render 
Server

ClientData ServerData ServerData ServerData ServerData ServerData Server

Depth Composite

Control, 
Display and Rendering

 of Small Data



ParaView’s Running Modes
Builtin aka 

Standalone aka 
Serial

all components within one process (client may be 
GUI or pvpython)
paraview   or  pvpython

Combined Server data processing and parallel rendering in MPI job of 
combined processes. control from TCP connected 
client.
mpiexec -n x pvserver &; paraview #  or 
pvpython  # + Connect

Batch server is an MPI job which directly runs a python 
script
mpiexec –n x pvbatch \
vis_script.py

DS RS Client

ClientDS RSDS RSDS RS

DS RSDS RSDS RS

DS = data server
RS = render server



Connect ParaView Client to the Server

Prerequisites:
⬣ Able to use ssh to connect to the server
⬣ Have a project allocation
⬣ Check paraview versions on server: module avail 

paraview (or check documentation)
⬣ Use client with the same major.minor version (5.12)

https://docs.alcf.anl.gov/polaris/visualization/paraview/


File > Connect > Fetch Servers
Bug in 5.12:
Fetch Servers 
does not fetch

git clone https://gitlab.kitware.com/paraview/pvsc.git Load Servers
ANL/server_polaris.pvsc
ANL/server_polaris_windows.pvsc

OR



Connect Unix/Mac

Mac Os: Install Xquartz



Connect Windows

Windows: Install PuTTY

quotes are required



Advanced Data Parallel Pipelines
⬣ Some operations will have problems.

● Example: External Faces



Advanced Data Parallel Pipelines
⬣ Ghost cells can solve most of these problems.



Balanced Partitioning + Ghost Cells
⬣ Automatic when reading structured data.
⬣ For unstructured data:

● Ghost Level Generator: creates ghost cells (if data is 
partitioned on disk)

● D3: also creates a balanced partition.

Extract Surface 
without ghost 

cells

Extract Surface 
after D3



Topics for future 
exploration



Python Scripting
⬣ Tools > Start Trace
⬣ Build visualization pipeline with UI
⬣ Tools > End Trace
⬣ Save Python script



User Defined Filters

Calculator Python Calculator
Programmable Filter

Python Algorithms

Plugins



Animation
⬣ Temporal data
⬣ Fly over your data
⬣ Animate filter 

parameters



Advanced Rendering
⬣ Physically Based 

Rendering (PBR)
⬣ Ray Tracing (Intel 

OSPRay, Nvidia 
OptiX)



Questions


